Sauerworld Forum

[SOLVED] Problem Opengl after compile the last SVN version

Kato

  • *
  • 16
  • +1/-0
[SOLVED] Problem Opengl after compile the last SVN version
« on: February 20, 2020, 12:45:12 pm »
Hi all, i recently build sauerbraten from the SVN r5691 version using Codeblocks, the compilation is ok , no problems appear, but when i launch the game from the bat file, sauerbraten ask me Opengl 2.0 or higher required, but i'm up to date with my video driver, Nvidia 442.19 drivers for a GTX 1060 3gb card, what's is wrong in my compilation ?

« Last Edit: February 21, 2020, 03:10:54 pm by Kato »

Kato

  • *
  • 16
  • +1/-0
Re: Problem Opengl
« Reply #1 on: February 21, 2020, 12:24:06 pm »
Well i downloaded the collect edition and compile it , i have no problem problem to launch it works fine, i don't know what happen with the last SVN version. :'(


EDIT: i just found my problem, a previous installation of sauerbraten keep some files in the folder :

"Documents\My Games\Sauerbraten" i have moved all files, and launch the SVN version freshly compiled, no more opengl error dialog box appear and new config files was writed.

I will try to port my mod "level design" on the last SVN version, not easy because the structure file of the "Octaedit.cpp" has changed between SVN version and Collect version, i failed the first tentative to compile it, i obtain a lots of errors.   
« Last Edit: February 21, 2020, 12:48:35 pm by Kato »