Sauerworld Forum

Sauerbraten Graphic Problem

alebrije

  • *
  • 19
  • +4/-0
    • JuGadores Latinos eXtremos
Sauerbraten Graphic Problem
« on: March 10, 2019, 07:11:59 pm »
Hi all.

The problem is when I am playing normally and the game freezes. The screen freezes, shuts down and goes back to "turn on" and that has happened to me very frequently. Even, as seen in the video, sometimes it takes me out of the server.
Sometimes this happens very often during a game in the sauerbraten and it even came to stop the system and had to restart with the key combination CTRL + ALT + PetSys + (REISUB).

I recorded a video with my cell phone where one of those moments in which the problem occurs is observed.

At some time check the messages of dmesg and this was what appeared:

Code: [Select]
[ 2526.926388] [drm:evergreen_packet3_check] *ERROR* bad SURFACE_SYNC
[ 2526.926392] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
[ 2671.972059] radeon 0000:00:01.0: evergreen_cs_track_validate_texture:911 mipmap [1] bo too small (layer size 16384, offset 65536, coffset 81920, max layer 1, depth 1, bo size 4096) level0 (128 128 1)
[ 2671.972070] radeon 0000:00:01.0: evergreen_cs_track_validate_texture:916 problematic surf: (64 64) (4 4 1 1 2 2048 2)
[ 2671.972075] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
[ 4389.270152] [drm:radeon_cs_packet_next_reloc] *ERROR* No packet3 for relocation for packet at 1880.
[ 4389.270160] [drm] ib[1880]=0xC0016900
[ 4389.270163] [drm] ib[1881]=0x00000060
[ 4389.270166] [drm] ib[1882]=0x00000001
[ 4389.270169] [drm:evergreen_packet3_check] *ERROR* bad SURFACE_SYNC
[ 4389.270173] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
[ 4429.887894] radeon 0000:00:01.0: ring 0 stalled for more than 10004msec
[ 4429.887904] radeon 0000:00:01.0: GPU lockup (waiting for 0x000000000022d575 last fence id 0x000000000022d572 on ring 0)
[ 4429.933823] radeon 0000:00:01.0: Saved 79 dwords of commands on ring 0.
[ 4429.933893] radeon 0000:00:01.0: GPU softreset: 0x00000009
[ 4429.933898] radeon 0000:00:01.0:   GRBM_STATUS               = 0xE7701828
[ 4429.933902] radeon 0000:00:01.0:   GRBM_STATUS_SE0           = 0xFD000003
[ 4429.933906] radeon 0000:00:01.0:   GRBM_STATUS_SE1           = 0x00000007
[ 4429.933909] radeon 0000:00:01.0:   SRBM_STATUS               = 0x20000040
[ 4429.933967] radeon 0000:00:01.0:   SRBM_STATUS2              = 0x00000000
[ 4429.933970] radeon 0000:00:01.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 4429.933974] radeon 0000:00:01.0:   R_008678_CP_STALLED_STAT2 = 0x00018000
[ 4429.933978] radeon 0000:00:01.0:   R_00867C_CP_BUSY_STAT     = 0x00008002
[ 4429.933981] radeon 0000:00:01.0:   R_008680_CP_STAT          = 0x80030243
[ 4429.933985] radeon 0000:00:01.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 4429.933989] radeon 0000:00:01.0:   R_00D834_DMA_STATUS_REG   = 0x44C83D57
[ 4429.933993] radeon 0000:00:01.0:   VM_CONTEXT0_PROTECTION_FAULT_ADDR   0x00000000
[ 4429.933996] radeon 0000:00:01.0:   VM_CONTEXT0_PROTECTION_FAULT_STATUS 0x00000000
[ 4429.934000] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00000000
[ 4429.934004] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x00000000
[ 4429.948272] radeon 0000:00:01.0: GRBM_SOFT_RESET=0x0000DF7B
[ 4429.948327] radeon 0000:00:01.0: SRBM_SOFT_RESET=0x00010100
[ 4429.949474] radeon 0000:00:01.0:   GRBM_STATUS               = 0x00003828
[ 4429.949477] radeon 0000:00:01.0:   GRBM_STATUS_SE0           = 0x00000007
[ 4429.949481] radeon 0000:00:01.0:   GRBM_STATUS_SE1           = 0x00000007
[ 4429.949485] radeon 0000:00:01.0:   SRBM_STATUS               = 0x20000040
[ 4429.949542] radeon 0000:00:01.0:   SRBM_STATUS2              = 0x00000000
[ 4429.949546] radeon 0000:00:01.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 4429.949549] radeon 0000:00:01.0:   R_008678_CP_STALLED_STAT2 = 0x00000000
[ 4429.949553] radeon 0000:00:01.0:   R_00867C_CP_BUSY_STAT     = 0x00000000
[ 4429.949556] radeon 0000:00:01.0:   R_008680_CP_STAT          = 0x00000000
[ 4429.949560] radeon 0000:00:01.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 4429.949564] radeon 0000:00:01.0:   R_00D834_DMA_STATUS_REG   = 0x44C83D57
[ 4429.949626] radeon 0000:00:01.0: GPU reset succeeded, trying to resume
[ 4430.139804] [drm] PCIE GART of 1024M enabled (table at 0x0000000000276000).
[ 4430.139914] radeon 0000:00:01.0: WB enabled
[ 4430.139917] radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff88023151cc00
[ 4430.140652] radeon 0000:00:01.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc900111b5a18
[ 4430.140653] radeon 0000:00:01.0: fence driver on ring 1 use gpu addr 0x0000000020000c04 and cpu addr 0xffff88023151cc04
[ 4430.140655] radeon 0000:00:01.0: fence driver on ring 2 use gpu addr 0x0000000020000c08 and cpu addr 0xffff88023151cc08
[ 4430.140657] radeon 0000:00:01.0: fence driver on ring 3 use gpu addr 0x0000000020000c0c and cpu addr 0xffff88023151cc0c
[ 4430.140659] radeon 0000:00:01.0: fence driver on ring 4 use gpu addr 0x0000000020000c10 and cpu addr 0xffff88023151cc10
[ 4430.158816] [drm] ring test on 0 succeeded in 3 usecs
[ 4430.158823] [drm] ring test on 3 succeeded in 3 usecs
[ 4430.158829] [drm] ring test on 4 succeeded in 3 usecs
[ 4430.204443] [drm] ring test on 5 succeeded in 2 usecs
[ 4430.224271] [drm] UVD initialized successfully.
[ 4430.228402] [drm] ib test on ring 0 succeeded in 0 usecs
[ 4430.228448] [drm] ib test on ring 3 succeeded in 0 usecs
[ 4430.228480] [drm] ib test on ring 4 succeeded in 0 usecs
[ 4430.249226] [drm] ib test on ring 5 succeeded
[ 4572.250987] [drm:radeon_cs_packet_next_reloc] *ERROR* No packet3 for relocation for packet at 1880.
[ 4572.250995] [drm] ib[1880]=0xC0016900
[ 4572.250998] [drm] ib[1881]=0x00000060
[ 4572.251001] [drm] ib[1882]=0x00000001
[ 4572.251004] [drm:evergreen_packet3_check] *ERROR* bad SURFACE_SYNC
[ 4572.251008] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
[ 4951.940490] radeon 0000:00:01.0: evergreen_surface_check_2d:277 texture pitch 248 invalid must be aligned with 32
[ 4951.940501] radeon 0000:00:01.0: evergreen_cs_track_validate_texture:826 texture invalid 0x03fc0781 0x400000ff 0x06880000 0x00000008 0xa0000004 0x8002045a
[ 4951.940506] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
[ 5495.711389] radeon 0000:00:01.0: ring 0 stalled for more than 10004msec
[ 5495.711399] radeon 0000:00:01.0: GPU lockup (waiting for 0x00000000002b3990 last fence id 0x00000000002b398d on ring 0)
[ 5495.755876] radeon 0000:00:01.0: Saved 79 dwords of commands on ring 0.
[ 5495.755946] radeon 0000:00:01.0: GPU softreset: 0x00000009
[ 5495.755963] radeon 0000:00:01.0:   GRBM_STATUS               = 0xA2721828
[ 5495.755968] radeon 0000:00:01.0:   GRBM_STATUS_SE0           = 0x1D800003
[ 5495.755974] radeon 0000:00:01.0:   GRBM_STATUS_SE1           = 0x00000007
[ 5495.755979] radeon 0000:00:01.0:   SRBM_STATUS               = 0x20000040
[ 5495.756038] radeon 0000:00:01.0:   SRBM_STATUS2              = 0x00000000
[ 5495.756043] radeon 0000:00:01.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 5495.756048] radeon 0000:00:01.0:   R_008678_CP_STALLED_STAT2 = 0x00010000
[ 5495.756053] radeon 0000:00:01.0:   R_00867C_CP_BUSY_STAT     = 0x00008006
[ 5495.756058] radeon 0000:00:01.0:   R_008680_CP_STAT          = 0x80038647
[ 5495.756063] radeon 0000:00:01.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 5495.756069] radeon 0000:00:01.0:   R_00D834_DMA_STATUS_REG   = 0x44C83D57
[ 5495.756075] radeon 0000:00:01.0:   VM_CONTEXT0_PROTECTION_FAULT_ADDR   0x00000000
[ 5495.756080] radeon 0000:00:01.0:   VM_CONTEXT0_PROTECTION_FAULT_STATUS 0x00000000
[ 5495.756085] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00000000
[ 5495.756091] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x00000000
[ 5495.770184] radeon 0000:00:01.0: GRBM_SOFT_RESET=0x0000DF7B
[ 5495.770240] radeon 0000:00:01.0: SRBM_SOFT_RESET=0x00010100
[ 5495.771387] radeon 0000:00:01.0:   GRBM_STATUS               = 0x00003828
[ 5495.771392] radeon 0000:00:01.0:   GRBM_STATUS_SE0           = 0x00000007
[ 5495.771396] radeon 0000:00:01.0:   GRBM_STATUS_SE1           = 0x00000007
[ 5495.771400] radeon 0000:00:01.0:   SRBM_STATUS               = 0x20000040
[ 5495.771457] radeon 0000:00:01.0:   SRBM_STATUS2              = 0x00000000
[ 5495.771461] radeon 0000:00:01.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 5495.771464] radeon 0000:00:01.0:   R_008678_CP_STALLED_STAT2 = 0x00000000
[ 5495.771468] radeon 0000:00:01.0:   R_00867C_CP_BUSY_STAT     = 0x00000000
[ 5495.771471] radeon 0000:00:01.0:   R_008680_CP_STAT          = 0x00000000
[ 5495.771475] radeon 0000:00:01.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 5495.771479] radeon 0000:00:01.0:   R_00D834_DMA_STATUS_REG   = 0x44C83D57
[ 5495.771542] radeon 0000:00:01.0: GPU reset succeeded, trying to resume
[ 5495.965344] [drm] PCIE GART of 1024M enabled (table at 0x0000000000276000).
[ 5495.965495] radeon 0000:00:01.0: WB enabled
[ 5495.965502] radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff88023151cc00
[ 5495.966232] radeon 0000:00:01.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc900111b5a18
[ 5495.966237] radeon 0000:00:01.0: fence driver on ring 1 use gpu addr 0x0000000020000c04 and cpu addr 0xffff88023151cc04
[ 5495.966241] radeon 0000:00:01.0: fence driver on ring 2 use gpu addr 0x0000000020000c08 and cpu addr 0xffff88023151cc08
[ 5495.966246] radeon 0000:00:01.0: fence driver on ring 3 use gpu addr 0x0000000020000c0c and cpu addr 0xffff88023151cc0c
[ 5495.966250] radeon 0000:00:01.0: fence driver on ring 4 use gpu addr 0x0000000020000c10 and cpu addr 0xffff88023151cc10
[ 5495.984524] [drm] ring test on 0 succeeded in 2 usecs
[ 5495.984535] [drm] ring test on 3 succeeded in 3 usecs
[ 5495.984544] [drm] ring test on 4 succeeded in 3 usecs
[ 5496.030205] [drm] ring test on 5 succeeded in 1 usecs
[ 5496.050228] [drm] UVD initialized successfully.
[ 5496.054857] [drm] ib test on ring 0 succeeded in 0 usecs
[ 5496.054897] [drm] ib test on ring 3 succeeded in 0 usecs
[ 5496.054927] [drm] ib test on ring 4 succeeded in 0 usecs
[ 5496.074805] [drm:uvd_v1_0_ib_test] *ERROR* radeon: failed to get create msg (-22).
[ 5496.094639] [drm:radeon_ib_ring_tests] *ERROR* radeon: failed testing IB on ring 5 (-22).
[ 5680.380802] radeon 0000:00:01.0: evergreen_surface_check_2d:277 texture pitch 1016 invalid must be aligned with 32
[ 5680.380809] radeon 0000:00:01.0: evergreen_cs_track_validate_texture:826 texture invalid 0x0ffc1f81 0x400000ff 0x06880000 0x0000000a 0xa0000004 0x8002045a
[ 5680.380812] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
[ 6036.920641] radeon 0000:00:01.0: evergreen_surface_check_2d:277 texture pitch 56 invalid must be aligned with 32
[ 6036.920651] radeon 0000:00:01.0: evergreen_cs_track_validate_texture:826 texture invalid 0x00fc0181 0x4000003f 0x06880000 0x00000006 0xa0000004 0x8002045a
[ 6036.920655] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
[ 6186.295172] radeon 0000:00:01.0: evergreen_surface_check_2d:277 texture pitch 56 invalid must be aligned with 32
[ 6186.295178] radeon 0000:00:01.0: evergreen_cs_track_validate_texture:826 texture invalid 0x00fc0181 0x4000003f 0x02000000 0x00000006 0xa0000004 0x80020447
[ 6186.295181] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
[ 6494.903898] systemd-hostnamed[4031]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!

And this was when I recorded the video:

Code: [Select]
[ 2484.248474] radeon 0000:00:01.0: ring 0 stalled for more than 10004msec
[ 2484.248485] radeon 0000:00:01.0: GPU lockup (waiting for 0x0000000000104215 last fence id 0x0000000000104211 on ring 0)
[ 2484.294911] radeon 0000:00:01.0: Saved 111 dwords of commands on ring 0.
[ 2484.294980] radeon 0000:00:01.0: GPU softreset: 0x00000009
[ 2484.294985] radeon 0000:00:01.0:   GRBM_STATUS               = 0xA2721828
[ 2484.294989] radeon 0000:00:01.0:   GRBM_STATUS_SE0           = 0x1D800003
[ 2484.294993] radeon 0000:00:01.0:   GRBM_STATUS_SE1           = 0x00000007
[ 2484.294997] radeon 0000:00:01.0:   SRBM_STATUS               = 0x20000040
[ 2484.295055] radeon 0000:00:01.0:   SRBM_STATUS2              = 0x00000000
[ 2484.295058] radeon 0000:00:01.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 2484.295062] radeon 0000:00:01.0:   R_008678_CP_STALLED_STAT2 = 0x00018000
[ 2484.295066] radeon 0000:00:01.0:   R_00867C_CP_BUSY_STAT     = 0x00008002
[ 2484.295070] radeon 0000:00:01.0:   R_008680_CP_STAT          = 0x80030243
[ 2484.295073] radeon 0000:00:01.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 2484.295077] radeon 0000:00:01.0:   R_00D834_DMA_STATUS_REG   = 0x44C83D57
[ 2484.295081] radeon 0000:00:01.0:   VM_CONTEXT0_PROTECTION_FAULT_ADDR   0x00000000
[ 2484.295085] radeon 0000:00:01.0:   VM_CONTEXT0_PROTECTION_FAULT_STATUS 0x00000000
[ 2484.295089] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00000000
[ 2484.295092] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x00000000
[ 2484.295890] radeon 0000:00:01.0: GRBM_SOFT_RESET=0x0000DF7B
[ 2484.295945] radeon 0000:00:01.0: SRBM_SOFT_RESET=0x00010100
[ 2484.297092] radeon 0000:00:01.0:   GRBM_STATUS               = 0x00003828
[ 2484.297096] radeon 0000:00:01.0:   GRBM_STATUS_SE0           = 0x00000007
[ 2484.297100] radeon 0000:00:01.0:   GRBM_STATUS_SE1           = 0x00000007
[ 2484.297103] radeon 0000:00:01.0:   SRBM_STATUS               = 0x20000040
[ 2484.297161] radeon 0000:00:01.0:   SRBM_STATUS2              = 0x00000000
[ 2484.297164] radeon 0000:00:01.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 2484.297168] radeon 0000:00:01.0:   R_008678_CP_STALLED_STAT2 = 0x00000000
[ 2484.297172] radeon 0000:00:01.0:   R_00867C_CP_BUSY_STAT     = 0x00000000
[ 2484.297175] radeon 0000:00:01.0:   R_008680_CP_STAT          = 0x00000000
[ 2484.297179] radeon 0000:00:01.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 2484.297183] radeon 0000:00:01.0:   R_00D834_DMA_STATUS_REG   = 0x44C83D57
[ 2484.297245] radeon 0000:00:01.0: GPU reset succeeded, trying to resume
[ 2484.487101] [drm] PCIE GART of 1024M enabled (table at 0x0000000000276000).
[ 2484.487208] radeon 0000:00:01.0: WB enabled
[ 2484.487211] radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff880231b94c00
[ 2484.487962] radeon 0000:00:01.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc900110b5a18
[ 2484.487964] radeon 0000:00:01.0: fence driver on ring 1 use gpu addr 0x0000000020000c04 and cpu addr 0xffff880231b94c04
[ 2484.487965] radeon 0000:00:01.0: fence driver on ring 2 use gpu addr 0x0000000020000c08 and cpu addr 0xffff880231b94c08
[ 2484.487967] radeon 0000:00:01.0: fence driver on ring 3 use gpu addr 0x0000000020000c0c and cpu addr 0xffff880231b94c0c
[ 2484.487969] radeon 0000:00:01.0: fence driver on ring 4 use gpu addr 0x0000000020000c10 and cpu addr 0xffff880231b94c10
[ 2484.506134] [drm] ring test on 0 succeeded in 3 usecs
[ 2484.506142] [drm] ring test on 3 succeeded in 3 usecs
[ 2484.506148] [drm] ring test on 4 succeeded in 3 usecs
[ 2484.551753] [drm] ring test on 5 succeeded in 2 usecs
[ 2484.571662] [drm] UVD initialized successfully.
[ 2484.579078] [drm] ib test on ring 0 succeeded in 0 usecs
[ 2484.579123] [drm] ib test on ring 3 succeeded in 0 usecs
[ 2484.579156] [drm] ib test on ring 4 succeeded in 0 usecs
[ 2484.599682] [drm] ib test on ring 5 succeeded
[ 2901.539224] radeon 0000:00:01.0: ring 0 stalled for more than 10004msec
[ 2901.539234] radeon 0000:00:01.0: GPU lockup (waiting for 0x000000000013812d last fence id 0x000000000013812a on ring 0)
[ 2901.581880] radeon 0000:00:01.0: Saved 111 dwords of commands on ring 0.
[ 2901.581950] radeon 0000:00:01.0: GPU softreset: 0x00000009
[ 2901.581955] radeon 0000:00:01.0:   GRBM_STATUS               = 0xA27E0828
[ 2901.581959] radeon 0000:00:01.0:   GRBM_STATUS_SE0           = 0x1D800001
[ 2901.581963] radeon 0000:00:01.0:   GRBM_STATUS_SE1           = 0x00000007
[ 2901.581967] radeon 0000:00:01.0:   SRBM_STATUS               = 0x20000040
[ 2901.582024] radeon 0000:00:01.0:   SRBM_STATUS2              = 0x00000000
[ 2901.582028] radeon 0000:00:01.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 2901.582032] radeon 0000:00:01.0:   R_008678_CP_STALLED_STAT2 = 0x00010000
[ 2901.582035] radeon 0000:00:01.0:   R_00867C_CP_BUSY_STAT     = 0x00008006
[ 2901.582039] radeon 0000:00:01.0:   R_008680_CP_STAT          = 0x80038647
[ 2901.582043] radeon 0000:00:01.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 2901.582046] radeon 0000:00:01.0:   R_00D834_DMA_STATUS_REG   = 0x44C83D57
[ 2901.582050] radeon 0000:00:01.0:   VM_CONTEXT0_PROTECTION_FAULT_ADDR   0x00000000
[ 2901.582054] radeon 0000:00:01.0:   VM_CONTEXT0_PROTECTION_FAULT_STATUS 0x00000000
[ 2901.582058] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x00000000
[ 2901.582061] radeon 0000:00:01.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x00000000
[ 2901.583751] radeon 0000:00:01.0: GRBM_SOFT_RESET=0x0000DF7B
[ 2901.583806] radeon 0000:00:01.0: SRBM_SOFT_RESET=0x00010100
[ 2901.584952] radeon 0000:00:01.0:   GRBM_STATUS               = 0x00003828
[ 2901.584956] radeon 0000:00:01.0:   GRBM_STATUS_SE0           = 0x00000007
[ 2901.584959] radeon 0000:00:01.0:   GRBM_STATUS_SE1           = 0x00000007
[ 2901.584963] radeon 0000:00:01.0:   SRBM_STATUS               = 0x20000040
[ 2901.585020] radeon 0000:00:01.0:   SRBM_STATUS2              = 0x00000000
[ 2901.585024] radeon 0000:00:01.0:   R_008674_CP_STALLED_STAT1 = 0x00000000
[ 2901.585027] radeon 0000:00:01.0:   R_008678_CP_STALLED_STAT2 = 0x00000000
[ 2901.585031] radeon 0000:00:01.0:   R_00867C_CP_BUSY_STAT     = 0x00000000
[ 2901.585034] radeon 0000:00:01.0:   R_008680_CP_STAT          = 0x00000000
[ 2901.585038] radeon 0000:00:01.0:   R_00D034_DMA_STATUS_REG   = 0x44C83D57
[ 2901.585042] radeon 0000:00:01.0:   R_00D834_DMA_STATUS_REG   = 0x44C83D57
[ 2901.585105] radeon 0000:00:01.0: GPU reset succeeded, trying to resume
[ 2901.778789] [drm] PCIE GART of 1024M enabled (table at 0x0000000000276000).
[ 2901.778947] radeon 0000:00:01.0: WB enabled
[ 2901.778954] radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff880231b94c00
[ 2901.779693] radeon 0000:00:01.0: fence driver on ring 5 use gpu addr 0x0000000000075a18 and cpu addr 0xffffc900110b5a18
[ 2901.779698] radeon 0000:00:01.0: fence driver on ring 1 use gpu addr 0x0000000020000c04 and cpu addr 0xffff880231b94c04
[ 2901.779702] radeon 0000:00:01.0: fence driver on ring 2 use gpu addr 0x0000000020000c08 and cpu addr 0xffff880231b94c08
[ 2901.779707] radeon 0000:00:01.0: fence driver on ring 3 use gpu addr 0x0000000020000c0c and cpu addr 0xffff880231b94c0c
[ 2901.779711] radeon 0000:00:01.0: fence driver on ring 4 use gpu addr 0x0000000020000c10 and cpu addr 0xffff880231b94c10
[ 2901.797985] [drm] ring test on 0 succeeded in 2 usecs
[ 2901.797995] [drm] ring test on 3 succeeded in 3 usecs
[ 2901.798004] [drm] ring test on 4 succeeded in 3 usecs
[ 2901.843696] [drm] ring test on 5 succeeded in 1 usecs
[ 2901.863566] [drm] UVD initialized successfully.
[ 2901.873207] [drm] ib test on ring 0 succeeded in 0 usecs
[ 2901.873264] [drm] ib test on ring 3 succeeded in 0 usecs
[ 2901.873293] [drm] ib test on ring 4 succeeded in 0 usecs
[ 2901.893200] [drm:uvd_v1_0_ib_test] *ERROR* radeon: failed to get create msg (-22).
[ 2901.913042] [drm:radeon_ib_ring_tests] *ERROR* radeon: failed testing IB on ring 5 (-22).

If any of you knows the possible solution to my problem, I would be grateful.

Linux Mint Debian Edition 2 (LMDE 2 Betsy)
Procesor: AMD APU A-8 5600K
Graphic: Radeon HD 7560D
Driver: Radeon

I got OpenSuse Leap, dont remember the version, but i got the same problem there.
Verba volant, scripta manent

alebrije

  • *
  • 19
  • +4/-0
    • JuGadores Latinos eXtremos
Re: Sauerbraten Graphic Problem
« Reply #1 on: March 12, 2019, 02:46:04 am »
Well, I've tried it with the vanilla client and the same thing happens.
So it has to be a driver problem.

Verba volant, scripta manent

Doko

  • **
  • 70
  • +4/-0
Re: Sauerbraten Graphic Problem
« Reply #2 on: March 12, 2019, 04:13:19 pm »
Something similar happens to me all the time, and i have no idea about what could be causing this  :-\
The only thing i realized is when this problem starts my CPU usage goes really high and so the temperature (around 80° or 90°) That's the only hint i could find, but i was too lazy to keep searching for a solution. The drivers, different clients, different video configurations didn't solved anything.

________________________________________________________________________________________________
PD: Tanto tiempo que no te veia  ;D
PD2: Si lo deseas le puedo preguntar a arCABAL, él usa Linux y algo debe saber. ¡Saludos!

Suicizer

  • ***
  • 139
  • +6/-5
Re: Sauerbraten Graphic Problem
« Reply #3 on: March 12, 2019, 11:16:46 pm »
Ask Eihrul for patching or so.

Although it does seem a driver-related issue.

Anyway, contact Eihrul (email, cubeengine.com at the forums, smoke signals, etc)